Large ddos attacks causing network lag spikes for some players

Incident Report for Rust Reborn

Resolved

This incident has not reoccured recently, marking as resolved.
Posted Dec 19, 2025 - 23:48 UTC

Update

The issue looks to be related mostly to upstreams or your internet service providers. Due to this it may be benefical to you to try using a VPN/Proxy to temporarily route around it.
Posted Dec 19, 2025 - 20:17 UTC

Update

This is affecting the majority of rust servers out there. The host is still looking into the situation.
Posted Dec 19, 2025 - 19:10 UTC

Identified

The issue has been identified to be related to attacks. The host is looking into the situation to see what they can do to remedy.
Posted Dec 19, 2025 - 18:10 UTC
This incident affected: EU Server and US Server.